PRICE     :     Freeware

WP Gallery Manager Requirements

WordPress 3.0+

PHP 5+

    X